OOMMF Home next up previous contents index
Next: Data Graph Display: mmGraph Up: OOMMF Documentation Previous: The 2D Micromagnetic Solver:

Data Table Display: mmDataTable

mmDataTable Screen Shot

The application mmDataTable provides a data display service to its client applications. It accepts data from clients and displays it in a window. Its typical use is to display the evolving values of quantities computed by a micromagnetic solver program.

mmDataTable may be started either by selecting the mmDataTable button on mmLaunch, or from the command line via

tclsh oommf.tcl mmDataTable [standard options] [-net <0|1>]

-net <0|1>
Disable or enable a server which allows the data displayed by mmDataTable to be updated by another application. By default, the server is enabled. When the server is disabled, mmProbEd is only useful if it is embedded in another application.

The client application(s) that send data to mmDataTable for display control the flow of data. The user, interacting with the mmDataTable window, controls how the data is displayed. Upon launch, mmDataTable displays only a menubar. Upon user request, a display window below the menubar displays data values.

Each message from a client contains a list of (name, value, units) triples containing data for display. For example, one element in the list might be {Magnetization 800000 A/m}. mmDataTable stores the latest value it receives for each name. Earlier values are discarded when new data arrives from a client.

mmDataTable does not support any data output or storage facilities. To save tabular data, use the mmGraph or mmArchive applications.

The Data menu holds a list of all the data names for which mmDataTable has received data. Initially, mmDataTable has received no data from any clients, so this menu is empty. As data arrives from clients, the menu fills with the list of data names. Each data name on the list lies next to a checkbutton. When the checkbutton is toggled from off to on, the corresponding data name and its value and units are displayed at the bottom of the display window. When the checkbutton is toggled from on to off, the corresponding data name is removed from the display window. In this way, the user selects from all the data received what is to be displayed. Selecting the dashed rule at the top of the Data menu detaches it so the user may easily click multiple checkbuttons.

Displayed data values can be individually selected (or deselected) with a left mouse button click on the display entry. Highlighting is used to indicated which data values are currently selected. The Options menu also contains commands to select or deselect all displayed values. The selected values can be copied into the cut-and-paste (clipboard) buffer with the CTRL-c key combination, or the Options|Copy menu command.

The data value selection mechanism may also be used in data value formatting control. The Options|Format menu command brings up a Format dialog box to change the justification and format specification string. (The latter is the conversion string passed to the Tcl format command, which uses the C printf format codes.) If the Adjust:Selected radiobutton is active, then the specification will be applied to only the currently selected (highlighted) data values. Alternately, if Adjust:All is active, then the specification will be applied to all data values, and will additionally become the default specification.

A right mouse button click on a display entry will select that entry, and bring up the Format with the justification and format specifications of the selected entry. These specifications, with any revisions, may then be applied to all of the selected entries.

The menu selection File|Exit terminates the mmDataTable application. The menu Help provides the usual help facilities.

OOMMF Home next up previous Contents index

OOMMF Documentation Team
January 15, 2004